Calculo do tempo de atendimento de um serviço.[Resolvido]

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Calculo do tempo de atendimento de um serviço.[Resolvido]

Mensagem por Patropi em Sab Jan 02, 2016 1:36 pm

Boa tarde José.

Tenho encontrado nos fóruns várias dúvidas, sobre o assunto, pesquisando na internet, encontrei num site gringo, a fórmula abaixo:

=SE(E(INT(StartDT)=INT(EndDT);NÃO(É.NÃO.DISP(CORRESP(INT(StartDT);HolidayList;0))));"0 days 0 hours"; SE(INT(StartDT)=INT(EndDT);"0 days " &ARRED(24*(EndDT-StartDT);2)&"hours";MÁXIMO(DIATRABALHOTOTAL(StartDT+1;EndDT-1;HolidayList);0)+INT(24*(((EndDT-INT(EndDT))-(StartDT-INT(StartDT)))+(DayEnd-DayStart))/(24*(DayEnd-DayStart)))&" days "&MOD(ARRED(((24*(EndDT-INT(EndDT)))-24*DayStart)+(24*DayEnd-(24*(StartDT-INT(StartDT))));2);ARRED((24*(DayEnd-DayStart));2))&" hours "))

Tentei adaptar a fórmula, sem utilizar intervalos nomeados, mas o resultado não é o correto.
Tentei fazer modificações, mas não consegui progresso. conforme pode ver na planilha.

sendspace.com b9lonm

se o link não funcionar --> *wwwpontosendspacepontocom/file/b9lonm

Um abraço!


Última edição por Patropi em Qui Jan 07, 2016 10:19 am, editado 1 vez(es)
avatar
Patropi
Membro
Membro

Mensagens : 7
Data de inscrição : 09/12/2015
Idade : 57
Localização : Campo Mourão, PR

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Calculo do tempo de atendimento de um serviço.[Resolvido]

Mensagem por Admin em Qua Jan 06, 2016 5:51 pm

Boa tarde, Patropi,

Encontrei uma pequena diferença entre a fórmula original e a que você colocou na planilha:

=SE(E(INT(D5)=INT(E5);NÃO(É.NÃO.DISP(CORRESP(INT(D5);$W$6:$W$18;0))));"0 dia 0 horas"; SE(INT(D5)=INT(E5);"0 dia " &ARRED(24*(E5-D5);2)&"horas";MÁXIMO(DIATRABALHOTOTAL(D5+1;E5-1;$W$6:$W$18);0)+INT(24*(((E5-INT(D5))-(D5-INT(D5)))+($AA$7-$AA$6))/(24*($AA$7-$AA$6)))&" dias "&MOD(ARRED(((24*(E5-INT(E5)))-24*$AA$6)+(24*$AA$7-(24*(D5-INT(D5))));2);ARRED((24*($AA$7-$AA$6));2))&" horas "))

Uma letra "D" colocada no lugar de uma letra "E", portanto a fórmula correta seria:

SE(E(INT(D5)=INT(E5);NÃO(É.NÃO.DISP(CORRESP(INT(D5);$W$6:$W$18;0))));"0 dias 0 horas"; SE(INT(D5)=INT(E5);"0 dias " &ARRED(24*(E5-D5);2)&"horas";MÁXIMO(DIATRABALHOTOTAL(D5+1;E5-1;$W$6:$W$18);0)+INT(24*(((E5-INT(E5))-(D5-INT(D5)))+($AA$7-$AA$6))/(24*($AA$7-$AA$6)))&" dias "&MOD(ARRED(((24*(E5-INT(E5)))-24*$AA$6)+(24*$AA$7-(24*(D5-INT(D5))));2);ARRED((24*($AA$7-$AA$6));2))&" horas "))

Abraço

Admin
Admin

Mensagens : 19
Data de inscrição : 26/11/2015
Idade : 51
Localização : São Paulo

Ver perfil do usuário http://exceljvalq.livreforum.com

Voltar ao Topo Ir em baixo

Re: Calculo do tempo de atendimento de um serviço.[Resolvido]

Mensagem por Patropi em Qui Jan 07, 2016 10:21 am

Bom dia José

Acho que tenho que trocar de óculos, pois verifiquei várias vezes essas células e não percebi a inversão das letras.

Como sempre a tua ajuda foi perfeita.

Um abraço e desculpe pelo trabalho.
avatar
Patropi
Membro
Membro

Mensagens : 7
Data de inscrição : 09/12/2015
Idade : 57
Localização : Campo Mourão, PR

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Calculo do tempo de atendimento de um serviço.[Resolvido]

Mensagem por Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum